Respondido

Mensagens Ativas - Template Bug BlipDesk


Reputação 1

Bom dia pessoal, percebi um possível erro no BlipDesk.

 

Quando envio mensagem ativa no Wpp usando o painel de campanhas da própria Blip, a mensagem é exibida normalmente no BlipDesk (na área circulada em vermelho abaixo).

Porém quando uso a API Blip, passando o nome do template e as variáveis, tudo funciona, envia mensagem corretamente para o wpp do cliente, mas a mensagem enviada não aparece no painel da BlipDesk.

Pode ver que no print abaixo que a mensagem não é exibida, tornando difícil o atendente entender o contexto da conversa que chegou pra ele.

Estuo usando um template com opção de botões de ação para resposta no corpo do chat.

Segue o JSON enviado para a API, citando o template que usamos e que foi construído na própria plataforma Blip. Podem ver que na imagem mais abaixo aparece só o nome do template

Faz sentido esse problema? Já viram algo parecido?

 

JSON envio da mensagem ativa:

{
"id": "{{$guid}}",
"to": "[email protected]",
"type": "application/json",
"content":
{
"type": "template",
"template":
{
"name": "cob_inadimplencia_boleto_2parcelas",
"language":
{
"code": "pt_BR",
"policy": "deterministic"
},
"components":
[
{
"type": "body",
"parameters":
[
{
"type": "text",
"text": "valor 1"
},
{
"type":"text",
"text":"valor 2"
}
]
}
]
}
}
}

 

JSON do redirecionamento para o fluxo específico do Bot:

{
"id": "{{$guid}}",
"to": "[email protected]",
"method": "set",
"uri": "/contexts/[email protected]/stateid@cb8d828f-xpto-6f174bfb7d56",
"type": "text/plain",
"resource": "8a72efd9-xpto-f68c2d31c7d9"
}

 

Print do problema no BlipDesk:

 

 

 

icon

Melhor resposta por Rafael_Figueiredo 10 June 2024, 17:33

Veja o original

4 comentários

Reputação 7
Crachá +3

Bom dia pessoal, percebi um possível erro no BlipDesk.

 

Quando envio mensagem ativa no Wpp usando o painel de campanhas da própria Blip, a mensagem é exibida normalmente no BlipDesk (na área circulada em vermelho abaixo).

Porém quando uso a API Blip, passando o nome do template e as variáveis, tudo funciona, envia mensagem corretamente para o wpp do cliente, mas a mensagem enviada não aparece no painel da BlipDesk.

Pode ver que no print abaixo que a mensagem não é exibida, tornando difícil o atendente entender o contexto da conversa que chegou pra ele.

Estuo usando um template com opção de botões de ação para resposta no corpo do chat.

Segue o JSON enviado para a API, citando o template que usamos e que foi construído na própria plataforma Blip. Podem ver que na imagem mais abaixo aparece só o nome do template

Faz sentido esse problema? Já viram algo parecido?

 

JSON envio da mensagem ativa:

{
"id": "{{$guid}}",
"to": "[email protected]",
"type": "application/json",
"content":
{
"type": "template",
"template":
{
"name": "cob_inadimplencia_boleto_2parcelas",
"language":
{
"code": "pt_BR",
"policy": "deterministic"
},
"components":
[
{
"type": "body",
"parameters":
[
{
"type": "text",
"text": "valor 1"
},
{
"type":"text",
"text":"valor 2"
}
]
}
]
}
}
}

 

JSON do redirecionamento para o fluxo específico do Bot:

{
"id": "{{$guid}}",
"to": "[email protected]",
"method": "set",
"uri": "/contexts/[email protected]/stateid@cb8d828f-xpto-6f174bfb7d56",
"type": "text/plain",
"resource": "8a72efd9-xpto-f68c2d31c7d9"
}

 

Print do problema no BlipDesk:

 

 

 

Olá @Spido tudo bem ? 

Informo que isso não é um erro nem falha e sim uma diferença entre as formas de fazer o envio que geram essa diferença entre os dois produtos, mas informo que os times estão cientes disso e deve ser tratado esse cenário em breve.

Reputação 1

Obrigado novamente @Rafael_Figueiredo pela rápida resposta.

 

Então, isto tende a ser corrigido em breve? Tem alguma ideia de quando?

Só para passar para o meu gestor, ele acreditava que nós estávamos enviando as informações incorretamente.

Desta forma não precisamos ajustar nada do nosso lado, só aguardar a correção, certo?

Reputação 7
Crachá +3

Obrigado novamente @Rafael_Figueiredo pela rápida resposta.

 

Então, isto tende a ser corrigido em breve? Tem alguma ideia de quando?

Só para passar para o meu gestor, ele acreditava que nós estávamos enviando as informações incorretamente.

Desta forma não precisamos ajustar nada do nosso lado, só aguardar a correção, certo?

Não tenho informação de prazo para esse ajuste, pois o time está trabalhando em outros reparos também. Quando tiver sido feito o reparo pode ter certeza que informaremos em um tópico aqui da community. 

Reputação 1

Perfeito, ficamos no aguardo então.

 

Obrigado pela ajuda.

 

Comente